Вопрос [C++] Plugin-SDK

Тема в разделе "C, C++", создана пользователем DEsTR0Y, 10 июн 2018.

Статус темы:
Закрыта.
  1. DEsTR0Y

    DEsTR0Y Участник

    Регистрация:
    8 июн 2018
    Сообщения:
    14
    Симпатии:
    1
    При сборке решения выбивает такую ошибку: 1>LINK : fatal error LNK1181: не удается открыть входной файл "plugin.lib"
    Проект создавался для GTA Sa, тип плагина: dll
    В чём может быть проблема?
     
  2. iAmerican

    iAmerican Свой человек

    Регистрация:
    17 фев 2014
    Сообщения:
    494
    Симпатии:
    148
    Что тут не понятного? Файла либо нет , либо путь неправильный
     
  3. DEsTR0Y

    DEsTR0Y Участник

    Регистрация:
    8 июн 2018
    Сообщения:
    14
    Симпатии:
    1
    Как проверить, есть этот файл или нет? Если нет, то где можно скачать, а если есть, то где можно настроить для него путь? Такое только с Plugin SDK, при создании обычной Dll библиотеки никаких ошибок нет
     
  4. iAmerican

    iAmerican Свой человек

    Регистрация:
    17 фев 2014
    Сообщения:
    494
    Симпатии:
    148
    Добавляем lib-файлы в проект MS Visual C++ | Blablacode(http://blablacode.ru/windows/79)
    Я думаю ты врятли осилишь Plugin SDK
     
  5. DEsTR0Y

    DEsTR0Y Участник

    Регистрация:
    8 июн 2018
    Сообщения:
    14
    Симпатии:
    1
    Все когда-то были новичками и порой тупили. В статье, в которой я и узнал про Plugin SDK, всё было довольно просто(там был пример изменения погоды). Ведь большинство действий делаются аналогично, не так ли? Делать что-то особо сложное я в ближайшее время не планирую, на данный момент мне надо только простенькие действия(вроде изменения погоды) и вывод текста в чат. Разве это так сложно?
    Да и попробовать все-таки надо, а вдруг получится. Лучше попробовать и ошибиться, чем не попробовать вообще и потом жалеть об этом.
     
  6. iAmerican

    iAmerican Свой человек

    Регистрация:
    17 фев 2014
    Сообщения:
    494
    Симпатии:
    148
    лучше бы с SF API начал , там все легче.
     
  7. DEsTR0Y

    DEsTR0Y Участник

    Регистрация:
    8 июн 2018
    Сообщения:
    14
    Симпатии:
    1
    Проблема в том, что я делаю для CRMP, а CRMP это по сути тот же SAMP 0.3е, только ещё и с запретом на загрузку всяких дополнений вроде Cleo, Asi loader, Sumpfuncs, Moonloader. Насколько мне известно, для CRMP не подходит SF API.
    И да, про обход мне известно, но с ним на большинство крупных проектов не пускает. Да и глюченный он, крашит постоянно
     
  8. iAmerican

    iAmerican Свой человек

    Регистрация:
    17 фев 2014
    Сообщения:
    494
    Симпатии:
    148
    понял принял.
     
  9. Apolo11

    Apolo11 Постоянный участник

    Регистрация:
    17 янв 2016
    Сообщения:
    57
    Симпатии:
    13
    SlonoBoyko/CRMP-Trainer(https://github.com/SlonoBoyko/CRMP-Trainer)
     
  10. DEsTR0Y

    DEsTR0Y Участник

    Регистрация:
    8 июн 2018
    Сообщения:
    14
    Симпатии:
    1
Статус темы:
Закрыта.